Phone: (818) 988-5231

SSC News: Adobe CS4 , Dymo Recall

SSC News: Adobe CS4 , Dymo Recall

Dymo Printer Power Supply Recal

We know that many of you have Dymo Label Printers.  Dymo has announced a recall of power supplies for some of their units for safety reasons.  This recall, which you can read about here, is for LabelWriter 400, 400 Turbo, Twin Turbo, Duo, and Desktop Mailing Solution Printers.  Please note that this does not affect all power supplies for these printers, only some of them.  If you have trouble verifying whether your power supply is affected, please give us a call.  If you only need one replacement, you can simply order it on-line here.  If you need more than one replacement, you will need to call them at 888-658-3904.  Please let us know if you have any questions.

Adobe CS4 Upgrades Intro Pricing

Many of you will be upgrading to Adobe CS4 this year, and we have learned that Adobe has an introductory price for volume licenses.  Most of you have this kind of license (where you have a certificate for x number of users) and can take advantage of this discount.   Last year we were telling clients to budget for $699 for a typical upgrade from a previous CS suite to the CS4 Design Standard Suite.  From now until February 28th, however, you can save $200 per license and get it for $499 when ordering from Adobe.   For those of you who need the CS4 Design Premium or Web Premium, they can be purchased for $599 instead of $799.  Since we typically recommend the Volume Licenses for clients with 10 or more computers, this is a $2000 savings ($4990 vs $6990 for 10 users).  You can learn more about it on Adobe’s site here.  Please let us know if you have any questions about these purchases or would like our assistance.

Adobe CS4 and Leopard

We have been asked by many clients whether Adobe CS4 will require an upgrade to Leopard (OS 10.5).  The answer is, it depends.  CS4 will run on Tiger (10.4.11 only), but many of the plugins and add-ons our clients use will require upgrading to Leopard.  For example, most of our clients use Suitcase for font management in conjunction with the Adobe CS suite.  For compatibility with CS4, Suitcase Fusion 2 is required and Fusion 2 will only run on Leopard (10.5).  Therefore if you are a Suitcase user and want to use CS 4, you will have to upgrade to Leopard because of a domino effect.  Additionally, many of the programs, like Photoshop and Suitcase, require a G5 or Intel processor.  This means if you are still working on an iBook or PowerBook (as opposed to a MacBook or MacBook Pro), you won’t be able to use some of the programs.

As always, if you have any questions about your equipment or your specific environment, please give us a call.